Gentoo Archives: gentoo-amd64

From: "Arttu V." <arttuv69@×××××.com>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] Major update problem
Date: Mon, 07 Feb 2011 14:09:07
In Reply to: [gentoo-amd64] Major update problem by Paul Stear
On 2/7/11, Paul Stear <gentoo@××××××××××××.com> wrote:
> What is @selected, I have never heard of this before, do I need to change > something? I can't seem to find this referenced in any documentation.
man emerge: "Three sets are currently always available: selected, system and world. selected contains the user-selected "world" packages that are listed in /var/lib/portage/world, and nested sets that may be listed in /var/lib/portage/world_sets."
> [blocks B ] kde-base/kwrite:4.5[-kdeprefix] ("kde-base/kwrite:4.5[- > kdeprefix]" is blocking kde-base/kwrite-4.6.0)
You most likely haven't enabled all of the new USE flags the new KDE 4.6.0 requires for several packages. device-mapper was one I had to enable, and also declarations or some such. I'm sorry, but I cannot remember all of the changes I had to make to get KDE SC 4.6 compiling. They can be worked out from the terrible mess portage prints out, but it takes a fair while of careful inspection. I hope someone else made better notes on the required changes. -- Arttu V.