Gentoo Archives: gentoo-amd64

From: Eric Augustus <shrike@×××××××××.com>
To: gentoo-amd64@l.g.o
Subject: [gentoo-amd64] USE=aac and blocking faad2 and mpeg4ip emerges
Date: Sun, 13 Nov 2005 16:30:30
I'm currently running into a problem with aac support in several
ebuilds that is causing blocks because media-libs/faad2 and
media-video/mpeg4ip cannot coexist.

The ebuilds I'm trying to install that have depends for USE=aac are:

app-pda/gtkpod - Requires media-libs/faad2 media-video/mpeg4ip
media-sound/easytag - Requires media-video/mpeg4ip
media-video/ffmpeg - Requires media-libs/faad2 media-libs/faac

This is certainly not an exhaustive list of ebuilds that have aac DEPENDS, but
what I use.

There appears to be a need for "virtual/aac" support.

I've chosen to stick with faad2 since it seems to be more common, and
added "-aac" to /etc/portage/package.use for those ebuilds that depend
on mpeg4ip.

Bugzilla bug 76212 sort of addresses this problem, but only with regards
to faac.

Any other workarounds?

Eric Augustus
A consultant is a person who borrows your watch, tells you what time it
is, pockets the watch, and sends you a bill for it.
gentoo-amd64@g.o mailing list


Subject Author
Re: [gentoo-amd64] USE=aac and blocking faad2 and mpeg4ip emerges "Olivier Crête" <tester@g.o>