Gentoo Archives: gentoo-amd64

From: Dale <rdalek1967@×××××.com>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] No LibX11 Libtool Archive Installed
Date: Mon, 28 Mar 2011 03:17:42
In Reply to: [gentoo-amd64] No LibX11 Libtool Archive Installed by Frank Peters
Frank Peters wrote:
> Hello, > > The latest GTK+-2.24.3 failed to build on my system because of the > following error: > > /bin/grep: /usr/lib64/ No such file or directory > /bin/sed: can't read /usr/lib64/ No such file or directory > libtool: link: `/usr/lib64/' is not a valid libtool archive > > The that is missing should be in the x11-libs/libX11 package. > But why is missing? > > I can emerge libX11 using USE="static-libs" or USE="-static-libs" > but is not produced in either case. > > The emerge log when building libX11 always shows the following: > > Removing unnecessary ... x11-libs/libX11-1.4.2/image/usr/lib64/ > Removing unnecessary ... x11-libs/libX11-1.4.2/image/usr/lib64/ > > So the .la files are being produced but are being removed afterwards. > > Does anyone else have a missing /usr/lib64/ file? > > Frank Peters > > >
I think I read on -dev that .la files were being removed. It seems to have been causing trouble when packages were being updating that were linked against each other. So, they made things so that they would work without them and removed them. That is oversimplified since it was a while back but I think that is normal nowadays. Someone correct me if I am wrong on this. Dale :-) :-)


Subject Author
Re: [gentoo-amd64] No LibX11 Libtool Archive Installed Nathan Phillip Brink <ohnobinki@××××××××××××××.net>