Gentoo Archives: gentoo-announce

From: Aaron Bauman <bman@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201710-08 ] Pacemaker: Multiple vulnerabilities
Date: Sun, 08 Oct 2017 14:15:55
Message-Id: 27923320.TI5PLdfZqL@localhost.localdomain
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201710-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Pacemaker: Multiple vulnerabilities
     Date: October 08, 2017
     Bugs: #546550, #599194
       ID: 201710-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Pacemaker, the worst of
which could result in the execution of arbitrary code.

Background
==========

Pacemaker is an Open Source, High Availability resource manager
suitable for both small and large clusters.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  sys-cluster/pacemaker        < 1.1.16                 >= 1.1.16  

Description
===========

Multiple vulnerabilities have been discovered in Pacemaker. Please
review the referenced CVE identifiers for details.

Impact
======

A remote attacker could execute arbitrary code or a local attacker
could escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Pacemaker users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-cluster/pacemaker-1.1.16 "

References
==========

[ 1 ] CVE-2015-1867
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-1867
[ 2 ] CVE-2016-7035
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-7035

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201710-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature