Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-60 ] QtCore: Multiple vulnerabilities
Date: Thu, 26 Mar 2020 18:53:31
Message-Id: 4a6e2a64-164f-99ed-5815-b177e1d50af7@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-60
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: QtCore: Multiple vulnerabilities
     Date: March 26, 2020
     Bugs: #699226, #707354
       ID: 202003-60

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in QtCore, the worst of which
could result in the execution of arbitrary code.

Background
==========

The Qt toolkit is a comprehensive C++ application development
framework.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-qt/qtcore              < 5.13.2-r2             *>= 5.12.3-r2
                                                        *>= 5.13.2-r2

Description
===========

Multiple vulnerabilities have been discovered in QtCore. Please review
the CVE identifiers referenced below for details.

Impact
======

An attacker could possibly execute arbitrary code with the privileges
of the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All QtCore 5.12.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-5.12.3-r2"

All QtCore 5.13.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-5.13.2-r2"

References
==========

[ 1 ] CVE-2019-18281
      https://nvd.nist.gov/vuln/detail/CVE-2019-18281
[ 2 ] CVE-2020-0569
      https://nvd.nist.gov/vuln/detail/CVE-2020-0569
[ 3 ] CVE-2020-0570
      https://nvd.nist.gov/vuln/detail/CVE-2020-0570

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-60

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature