Gentoo Archives: gentoo-announce

From: Aaron Bauman <bman@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201812-01 ] PHP: Multiple vulnerabilities
Date: Sun, 02 Dec 2018 15:53:14
Message-Id: 20181202154532.GA16376@monkey
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201812-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: PHP: Multiple vulnerabilities
     Date: December 02, 2018
     Bugs: #658092, #666256
       ID: 201812-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PHP, the worst of which
could result in a Denial of Service condition.

Background
==========

PHP is an open source general-purpose scripting language that is
especially suited for web development.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php                *< 5.6.38                 *>= 5.6.38 
                                 *< 7.0.32                 *>= 7.0.32 
                                 *< 7.1.22                 *>= 7.1.22 
                                  < 7.2.10                  >= 7.2.10 

Description
===========

Multiple vulnerabilities have been discovered in PHP. Please review the
referenced CVE identifiers for details.

Impact
======

An attacker could cause a Denial of Service condition or obtain
sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 5.6.X users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.38"

All PHP 7.0.X users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.32"

All PHP 7.1.X users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.1.22"

All PHP 7.2.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.10"

References
==========

[ 1 ] CVE-2018-10545
      https://nvd.nist.gov/vuln/detail/CVE-2018-10545
[ 2 ] CVE-2018-10546
      https://nvd.nist.gov/vuln/detail/CVE-2018-10546
[ 3 ] CVE-2018-10548
      https://nvd.nist.gov/vuln/detail/CVE-2018-10548
[ 4 ] CVE-2018-10549
      https://nvd.nist.gov/vuln/detail/CVE-2018-10549
[ 5 ] CVE-2018-17082
      https://nvd.nist.gov/vuln/detail/CVE-2018-17082

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201812-01

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature