Gentoo Archives: gentoo-announce

From: Aaron Bauman <bman@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201710-09 ] PCRE2: Multiple vulnerabilities
Date: Sun, 08 Oct 2017 14:44:14
Message-Id: 4171462.73fHDU6EeL@localhost.localdomain
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201710-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: PCRE2: Multiple vulnerabilities
     Date: October 08, 2017
     Bugs: #614050, #617942, #617944
       ID: 201710-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PCRE2, the worst of which
may allow remote attackers to execute arbitrary code.

Background
==========

PCRE2 is a project based on PCRE (Perl Compatible Regular Expressions)
which has a new and revised API.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libpcre2            < 10.30                    >= 10.30 

Description
===========

Multiple vulnerabilities have been discovered in PCRE2. Please review
the referenced CVE identifiers for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process, cause a Denial of Service condition, or have
other unspecified impacts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PCRE2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libpcre2-10.30"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2017-7186
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7186
[ 2 ] CVE-2017-8399
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8399
[ 3 ] CVE-2017-8786
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8786

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201710-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature