Gentoo Archives: gentoo-announce

From: Karl Trygve Kalleberg <karltk@×××××××.no>
To: gentoo-announce@g.o
Subject: [gentoo-announce] Updates to the JDK/JRE scheme again
Date: Tue, 29 Jan 2002 09:24:17
There have been some updates to the JDK/JRE system that might require you
to update and remerge your JDK/JRE. (emerge rsync ; emerge

If you run into problems with Java, first update your JRE/JDK. You will
not be required to download any binaries, it is only the Gentoo-specific
setup that has changed.

Changes include:
* Support for the IBM JDK and JREs. I have had problems with the IBM
browser-plugin, but  I am leaving it enabled until I get flames about its
instability as we're still pre-1.0. * Merging the JRE after the JDK will
no longer bust the paths.* You can now query java-config about both JDK
and JRE settings if both are installed.* Tomcat-4.0.1 is back  

Still not resolved properly is:
* emerge rsync ; emerge --world update will try to install both the JRE
and JDK, even though  the JDK supercedes the JRE if installed. Workaround:
Always make certain  /etc/make.profile/virtuals uses the
<yourfavourite>-jdk to resolve the jre before  doing emerge update. This
should only affect people with the JDK installed.

Keep the bug reports coming ;)

Karl T