Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-19 ] PPP: Buffer overflow
Date: Sun, 15 Mar 2020 03:06:27
Message-Id: 03f36110-9f43-98a7-bced-14c6edc3cc15@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: PPP: Buffer overflow
     Date: March 15, 2020
     Bugs: #710308
       ID: 202003-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow in PPP might allow a remote attacker to execute
arbitrary code.

Background
==========

PPP is a Unix implementation of the Point-to-Point Protocol.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-dialup/ppp               < 2.4.8                    >= 2.4.8

Description
===========

It was discovered that bounds check in PPP for the rhostname was
improperly constructed in the EAP request and response functions.

Impact
======

A remote attacker, by sending specially crafted authentication data,
could possibly execute arbitrary code with the privileges of the
process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PPP users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-dialup/ppp-2.4.8"

References
==========

[ 1 ] CVE-2020-8597
      https://nvd.nist.gov/vuln/detail/CVE-2020-8597

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-19

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature