Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-54 ] Pure-FTPd: Multiple vulnerabilities
Date: Wed, 25 Mar 2020 19:01:33
Message-Id: 78d2740a-21f9-b987-d69d-a19db97ef02e@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-54
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: Pure-FTPd: Multiple vulnerabilities
     Date: March 25, 2020
     Bugs: #711124
       ID: 202003-54

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Pure-FTPd, the worst of
which could allow remote attackers to cause a Denial of Service
condition.

Background
==========

Pure-FTPd is a fast, production-quality and standards-compliant FTP
server.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-ftp/pure-ftpd          < 1.0.49-r2              >= 1.0.49-r2

Description
===========

Multiple vulnerabilities have been discovered in Pure-FTPd. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly cause a Denial of Service condition or
cause an information disclosure.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Pure-FTPd users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-ftp/pure-ftpd-1.0.49-r2"

References
==========

[ 1 ] CVE-2020-9274
      https://nvd.nist.gov/vuln/detail/CVE-2020-9274
[ 2 ] CVE-2020-9365
      https://nvd.nist.gov/vuln/detail/CVE-2020-9365

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-54

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature