Gentoo Archives: gentoo-announce

From: Aaron Bauman <bman@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201812-06 ] CouchDB: Multiple vulnerabilities
Date: Sat, 15 Dec 2018 20:14:11
Message-Id: 20181215200903.GA10488@monkey
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201812-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: CouchDB: Multiple vulnerabilities
     Date: December 15, 2018
     Bugs: #630796, #660908, #663164
       ID: 201812-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in CouchDB, the worst of which
could lead to the remote execution of code.

Background
==========

Apache CouchDB is a distributed, fault-tolerant and schema-free
document-oriented database.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-db/couchdb               <= 2.1.2                 Vulnerable!
    -------------------------------------------------------------------
     NOTE: Certain packages are still vulnerable. Users should migrate
           to another package if one is available or wait for the
           existing packages to be marked stable by their
           architecture maintainers.

Description
===========

Multiple vulnerabilities have been discovered in CouchDB. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could execute arbitrary code or escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo has discontinued support for CouchDB and recommends that users
unmerge the package:

  # emerge --unmerge "dev-db/couchdb"

References
==========

[ 1 ] CVE-2018-11769
      https://nvd.nist.gov/vuln/detail/CVE-2018-11769
[ 2 ] CVE-2018-8007
      https://nvd.nist.gov/vuln/detail/CVE-2018-8007

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201812-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature