Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-09 ] OpenID library for Ruby: Server Side Request Forgery
Date: Sat, 14 Mar 2020 15:05:20
Message-Id: a2ac7553-0cb9-f5f5-90f7-f1ad353c02c9@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: OpenID library for Ruby: Server Side Request Forgery
     Date: March 14, 2020
     Bugs: #698464
       ID: 202003-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in OpenID library for Ruby at worst might allow an
attacker to bypass authentication.

Background
==========

A Ruby library for verifying and serving OpenID identities.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-ruby/ruby-openid         < 2.9.2                    >= 2.9.2

Description
===========

It was discovered that OpenID library for Ruby performed discovery
first, and then verification.

Impact
======

A remote attacker could possibly change the URL used for discovery and
trick the server into connecting to the URL. This server in turn could
be a private server not
publicly accessible.

In addition, if the client that uses this library discloses connection
errors, this in turn could disclose information from the private server
to the attacker.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ruby-openid users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-ruby/ruby-openid-2.9.2"

References
==========

[ 1 ] CVE-2019-11027
      https://nvd.nist.gov/vuln/detail/CVE-2019-11027

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature