Gentoo Archives: gentoo-announce

From: Mikle Kolyada <zlogene@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] [ GLSA 201408-07 ] ModPlug XMMS Plugin: Multiple vulnerabilities
Date: Sat, 16 Aug 2014 18:17:35
Message-Id: 53EF9C23.1010506@gentoo.org
1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
2 Gentoo Linux Security Advisory GLSA 201408-07
3 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4 http://security.gentoo.org/
5 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
6
7 Severity: Normal
8 Title: ModPlug XMMS Plugin: Multiple vulnerabilities
9 Date: August 16, 2014
10 Bugs: #480388
11 ID: 201408-07
12
13 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
14
15 Synopsis
16 ========
17
18
19
20 Multiple vulnerabilities have been found in ModPlug XMMS Plugin, worst
21 of which allows remote attackers to execute arbitrary code.
22
23 Background
24 ==========
25
26 ModPlug XMMS Plugin is a library for playing MOD-like music files
27
28 Affected packages
29 =================
30
31 -------------------------------------------------------------------
32 Package / Vulnerable / Unaffected
33 -------------------------------------------------------------------
34 1 media-libs/libmodplug < 0.8.8.5 >= 0.8.8.5
35
36 Description
37 ===========
38
39 Multiple vulnerabilities have been discovered in ModPlug XMMS Plugin.
40 Please review the CVE identifiers referenced below for details.
41
42 Impact
43 ======
44
45 A remote attacker could possibly execute arbitrary code with the
46 privileges of the process, or cause a Denial of Service condition.
47
48 Workaround
49 ==========
50
51 There is no known workaround at this time.
52
53 Resolution
54 ==========
55
56 All ModPlug XMMS Plugin users should upgrade to the latest version:
57
58 # emerge --sync
59 # emerge --ask --oneshot --verbose ">=media-libs/libmodplug-0.8.8.5"
60
61 References
62 ==========
63
64 [ 1 ] CVE-2013-4233
65 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4233
66 [ 2 ] CVE-2013-4234
67 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4234
68
69 Availability
70 ============
71
72 This GLSA and any updates to it are available for viewing at
73 the Gentoo Security Website:
74
75 http://security.gentoo.org/glsa/glsa-201408-07.xml
76
77 Concerns?
78 =========
79
80 Security is a primary focus of Gentoo Linux and ensuring the
81 confidentiality and security of our users' machines is of utmost
82 importance to us. Any security concerns should be addressed to
83 security@g.o or alternatively, you may file a bug at
84 https://bugs.gentoo.org.
85
86 License
87 =======
88
89 Copyright 2014 Gentoo Foundation, Inc; referenced text
90 belongs to its owner(s).
91
92 The contents of this document are licensed under the
93 Creative Commons - Attribution / Share Alike license.
94
95 http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature