Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-59 ] libvpx: User-assisted execution of arbitrary code
Date: Thu, 26 Mar 2020 18:41:54
Message-Id: 88417463-217e-bed6-505b-7a410ceeb273@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-59
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: libvpx: User-assisted execution of arbitrary code
     Date: March 26, 2020
     Bugs: #701834
       ID: 202003-59

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in libvpx, the worst of which
could result in the execution of arbitrary code.

Background
==========

libvpx is the VP8 codec SDK used to encode and decode video streams,
typically within a WebM format media file.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-libs/libvpx            < 1.8.1                *>= 1.7.0-r1
                                                            *>= 1.8.1

Description
===========

Multiple vulnerabilities have been discovered in libvpx. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to open a specially crafted media
file, possibly resulting in the execution of arbitrary code with the
privileges of the user running the application, or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libvpx 1.7.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libvpx-1.7.0-r1"

All libvpx 1.8.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libvpx-1.8.1"

References
==========

[ 1 ] CVE-2019-9232
      https://nvd.nist.gov/vuln/detail/CVE-2019-9232
[ 2 ] CVE-2019-9325
      https://nvd.nist.gov/vuln/detail/CVE-2019-9325
[ 3 ] CVE-2019-9371
      https://nvd.nist.gov/vuln/detail/CVE-2019-9371
[ 4 ] CVE-2019-9433
      https://nvd.nist.gov/vuln/detail/CVE-2019-9433

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-59

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature