Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-43 ] Apache Tomcat: Multiple vulnerabilities
Date: Thu, 19 Mar 2020 17:18:28
Message-Id: 0600a751-2ff8-192b-77fa-344c5a8aa808@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-43
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Apache Tomcat: Multiple vulnerabilities
     Date: March 19, 2020
     Bugs: #692402, #706208, #710656
       ID: 202003-43

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Apache Tomcat, the worst
of which could lead to arbitrary code execution.

Background
==========

Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-servers/tomcat           < 8.5.51                 >= 7.0.100
                                                            >= 8.5.51

Description
===========

Multiple vulnerabilities have been discovered in Apache Tomcat. Please
review the CVE identifiers referenced below for details.

Impact
======

An attacker could possibly smuggle HTTP requests or execute arbitrary
code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Apache Tomcat 7.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.100:7"

All Apache Tomcat 8.5.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.5.51:8.5"

References
==========

[ 1 ] CVE-2019-0221
      https://nvd.nist.gov/vuln/detail/CVE-2019-0221
[ 2 ] CVE-2019-12418
      https://nvd.nist.gov/vuln/detail/CVE-2019-12418
[ 3 ] CVE-2019-17563
      https://nvd.nist.gov/vuln/detail/CVE-2019-17563
[ 4 ] CVE-2020-1938
      https://nvd.nist.gov/vuln/detail/CVE-2020-1938

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-43

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature