Gentoo Archives: gentoo-announce

From: Chris Reffett <creffett@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] [ GLSA 201401-01 ] Libgdiplus: Arbitrary code execution
Date: Sun, 05 Jan 2014 00:20:06
Message-Id: 52C8A4A6.2090202@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201401-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Libgdiplus: Arbitrary code execution
     Date: January 05, 2014
     Bugs: #334101
       ID: 201401-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflow vulnerabilities in Libgdiplus may allow
remote attackers to execute arbitrary code.

Background
==========

Libgdiplus is the Mono library that provide a GDI+ comptible API on
non-Windows operating systems.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-dotnet/libgdiplus       < 2.6.7-r1               >= 2.6.7-r1

Description
===========

An integer overflow flaw has been discovered in Libgdiplus.

Impact
======

A remote attacker could entice a user to open a specially-crafted
TIFF/JPEG/BMP file, potentially resulting in arbitrary code execution.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Libgdiplus users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-dotnet/libgdiplus-2.6.7-r1"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since September 12, 2010. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-1526
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1526

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201401-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature