Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201910-01 ] PHP: Arbitrary code execution
Date: Fri, 25 Oct 2019 11:11:10
Message-Id: 077ed0fe-a48d-af3f-c143-f740af85f2c8@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201910-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: PHP: Arbitrary code execution
     Date: October 25, 2019
     Bugs: #698452
       ID: 201910-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in PHP might allow an attacker to execute arbitrary
code.

Background
==========

PHP is an open source general-purpose scripting language that is
especially suited for web development.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php                 < 7.1.33                  >= 7.1.33
                                  < 7.2.24                  >= 7.2.24
                                  < 7.3.11                  >= 7.3.11

Description
===========

A underflow in env_path_info in PHP-FPM under certain configurations
can be exploited to gain remote code execution.

Impact
======

A remote attacker, by sending special crafted HTTP requests, could
possibly execute arbitrary code with the privileges of the process, or
cause a Denial of Service condition.

Workaround
==========

If patching is not feasible, the suggested workaround is to include
checks to verify whether or not a file exists before passing to PHP.

Resolution
==========

All PHP 7.1 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.1.33"

All PHP 7.2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.24"

All PHP 7.3 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.3.11"

References
==========

[ 1 ] CVE-2019-11043
      https://nvd.nist.gov/vuln/detail/CVE-2019-11043

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201910-01

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature