Gentoo Archives: gentoo-announce

From: Kristian Fiskerstrand <k_f@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201705-05 ] FFmpeg: Multiple vulnerabilities
Date: Tue, 09 May 2017 19:36:34
Message-Id: 8f382098-f9ca-1c4d-d76c-90ebec213c20@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201705-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: FFmpeg: Multiple vulnerabilities
     Date: May 09, 2017
     Bugs: #608868, #610810
       ID: 201705-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in FFmpeg, the worst of which
allows remote attackers to execute arbitrary code.

Background
==========

FFmpeg is a complete, cross-platform solution to record, convert and
stream audio and video.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-video/ffmpeg           < 3.2.4                    >= 3.2.4
  2  media-plugins/gst-plugins-libav
                                  < 1.10.4                  >= 1.10.4
    -------------------------------------------------------------------
     2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in FFmpeg. Please review
the CVE identifiers referenced below for details.

gst-plugins-libav is affected because this package is bundling a
vulnerable FFmpeg version.

Impact
======

A remote attacker could entice a user or automated system using FFmpeg
to process a specially crafted file, resulting in the execution of
arbitrary code or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All FFmpeg users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-3.2.4"

All gst-plugins-libav users should upgrade to the latest version:

  # emerge --sync
  # emerge -a --oneshot -v ">=media-plugins/gst-plugins-libav-1.10.4"

References
==========

[ 1 ] CVE-2017-5024
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5024
[ 2 ] CVE-2017-5025
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5025

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201705-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature