Gentoo Archives: gentoo-announce

From: Aaron Bauman <bman@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201810-04 ] ImageMagick: Security hardening
Date: Sat, 06 Oct 2018 17:13:34
Message-Id: 20181006171035.GF31755@monkey
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201810-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: ImageMagick: Security hardening
     Date: October 06, 2018
     Bugs: #664236
       ID: 201810-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Due to multiple vulnerabilities in various coders used by ImageMagick,
Gentoo Linux now installs a policy.xml file which will restrict coder
usage by default.

Background
==========

ImageMagick is a collection of tools and libraries for many image
formats.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-gfx/imagemagick     < 6.9.10.10-r1         >= 6.9.10.10-r1 
                               < 7.0.8.10-r1           >= 7.0.8.10-r1 

Description
===========

If you process an image with ImageMagick and don't validate the file
before (e.g. check magic byte), ImageMagick will call any coders found
in the given file. So if ImageMagick will find Ghostscript for example,
it will call Ghostscript.

Due to multiple -dSAFER sandbox bypass vulnerabilities in Ghostscript,
this can lead to arbitrary code execution.

To mitigate this problem we install a policy.xml file by default which
will disable PS, EPS, PDF, and XPS coders.

Impact
======

A remote attacker, by enticing a user to process a specially crafted
image file, could execute arbitrary code with the privileges of the
process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ImageMagick 6 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=media-gfx/imagemagick-6.9.10.10-r1"

All ImageMagick 7 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=media-gfx/imagemagick-7.0.8.10-r1"

References
==========

[ 1 ] Ghostscript contains multiple -dSAFER sandbox bypass
      vulnerabilities (VU#332928)
      https://www.kb.cert.org/vuls/id/332928

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201810-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature