Gentoo Archives: gentoo-announce

From: Aaron Bauman <bman@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201911-03 ] Oniguruma: Multiple vulnerabilities
Date: Thu, 07 Nov 2019 19:17:33
Message-Id: 20191107190839.GC35641@bubba.lan
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201911-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Oniguruma: Multiple vulnerabilities
     Date: November 07, 2019
     Bugs: #691832
       ID: 201911-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Oniguruma, the worst of
which could result in the arbitrary execution of code.

Background
==========

Oniguruma is a regular expression library.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/oniguruma           < 6.9.3                    >= 6.9.3 

Description
===========

Multiple vulnerabilities have been discovered in Oniguruma. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker, by enticing a user to process a specially crafted
string using an application linked against Oniguruma, could possibly
execute arbitrary code with the privileges of the process or cause a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Oniguruma users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/oniguruma-6.9.3"

References
==========

[ 1 ] CVE-2019-13224
      https://nvd.nist.gov/vuln/detail/CVE-2019-13224
[ 2 ] CVE-2019-13225
      https://nvd.nist.gov/vuln/detail/CVE-2019-13225

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201911-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature