Gentoo Archives: gentoo-announce

From: Kristian Fiskerstrand <k_f@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] [ GLSA 201408-08 ] file: Denial of Service
Date: Fri, 29 Aug 2014 09:08:23
Message-Id: 540041AB.6090801@gentoo.org
1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
2 Gentoo Linux Security Advisory GLSA 201408-08
3 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4 http://security.gentoo.org/
5 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
6
7 Severity: Normal
8 Title: file: Denial of Service
9 Date: August 26, 2014
10 Bugs: #505534
11 ID: 201408-08
12
13 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
14
15 Synopsis
16 ========
17
18 A vulnerability in file could result in Denial of Service.
19
20 Background
21 ==========
22
23 file is a utility that guesses a file format by scanning binary data
24 for patterns.
25
26 Affected packages
27 =================
28
29 -------------------------------------------------------------------
30 Package / Vulnerable / Unaffected
31 -------------------------------------------------------------------
32 1 sys-apps/file < 5.15 >= 5.15
33
34 Description
35 ===========
36
37 BEGIN regular expression in the awk script detector in
38 magic/Magdir/commands uses multiple wildcards with unlimited
39 repetitions.
40
41 Impact
42 ======
43
44 A context-dependent attacker could entice a user to open a specially
45 crafted file, possibly resulting in a Denial of Service condition.
46
47 Workaround
48 ==========
49
50 There is no known workaround at this time.
51
52 Resolution
53 ==========
54
55 All file users should upgrade to the latest version:
56
57 # emerge --sync
58 # emerge --ask --oneshot --verbose ">= sys-apps/file-5.15"
59
60 References
61 ==========
62
63 [ 1 ] CVE-2013-7345
64 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-7345
65
66 Availability
67 ============
68
69 This GLSA and any updates to it are available for viewing at
70 the Gentoo Security Website:
71
72 http://security.gentoo.org/glsa/glsa-201408-08.xml
73
74 Concerns?
75 =========
76
77 Security is a primary focus of Gentoo Linux and ensuring the
78 confidentiality and security of our users' machines is of utmost
79 importance to us. Any security concerns should be addressed to
80 security@g.o or alternatively, you may file a bug at
81 https://bugs.gentoo.org.
82
83 License
84 =======
85
86 Copyright 2014 Gentoo Foundation, Inc; referenced text
87 belongs to its owner(s).
88
89 The contents of this document are licensed under the
90 Creative Commons - Attribution / Share Alike license.
91
92 http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature