Gentoo Archives: gentoo-announce

From: Robert Buchholz <rbu@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200907-13 ] PulseAudio: Local privilege escalation
Date: Thu, 16 Jul 2009 14:32:34
Message-Id: 200907161620.05267.rbu@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PulseAudio: Local privilege escalation
      Date: July 16, 2009
      Bugs: #276986
        ID: 200907-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in PulseAudio may allow a local user to execute code
with escalated privileges.

Background
==========

PulseAudio is a network-enabled sound server with an advanced plug-in
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package                 /   Vulnerable   /             Unaffected
    -------------------------------------------------------------------
  1  media-sound/pulseaudio      < 0.9.9-r54              >= 0.9.9-r54

Description
===========

Tavis Ormandy and Julien Tinnes of the Google Security Team discovered
that the pulseaudio binary is installed setuid root, and does not drop
privileges before re-executing itself. The vulnerability has
independently been reported to oCERT by Yorick Koster.

Impact
======

A local user who has write access to any directory on the file system
containing /usr/bin can exploit this vulnerability using a race
condition to execute arbitrary code with root privileges.

Workaround
==========

Ensure that the file system holding /usr/bin does not contain
directories that are writable for unprivileged users.

Resolution
==========

All PulseAudio users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot -v ">=media-sound/pulseaudio-0.9.9-r54"

References
==========

  [ 1 ] CVE-2009-1894
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1894

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature