Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 202003-03 ] PostgreSQL: Multiple vulnerabilities
Date: Thu, 12 Mar 2020 20:23:58
Message-Id: 4a963aeb-e1fa-7555-88e9-1a9c1cd0b3ad@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202003-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: PostgreSQL: Multiple vulnerabilities
     Date: March 12, 2020
     Bugs: #685846, #688420, #709708
       ID: 202003-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PostgreSQL, the worst of
which could result in the execution of arbitrary code.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql          < 9.4.26:9.4            >= 9.4.26:9.4
                                < 9.5.21:9.5            >= 9.5.21:9.5
                                < 9.6.17:9.6            >= 9.6.17:9.6
                                 < 10.12:10               >= 10.12:10
                                 < 11.7:11                 >= 11.7:11
                                 < 12.2:12                 >= 12.2:12

Description
===========

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process, bypass certain client-side connection
security features, read arbitrary server memory, alter certain data or
cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.4.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.4.26:9.4"

All PostgreSQL 9.5.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.21:9.5"

All PostgreSQL 9.6.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.17:9.6"

All PostgreSQL 10.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.12:10"

All PostgreSQL 11.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.7:11"

All PostgreSQL 12.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-12.2:12"

References
==========

[ 1 ] CVE-2019-10129
      https://nvd.nist.gov/vuln/detail/CVE-2019-10129
[ 2 ] CVE-2019-10130
      https://nvd.nist.gov/vuln/detail/CVE-2019-10130
[ 3 ] CVE-2019-10164
      https://nvd.nist.gov/vuln/detail/CVE-2019-10164
[ 4 ] CVE-2020-1720
      https://nvd.nist.gov/vuln/detail/CVE-2020-1720

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202003-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature