Gentoo Archives: gentoo-announce

From: Pierre-Yves Rofes <py@g.o>
To: gentoo-announce@l.g.o
Cc: full-disclosure@××××××××××××××.uk, bugtraq@×××××××××××××.com, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] ERRATA: [ GLSA 200711-20 ] Pioneers: Multiple Denials of Service
Date: Thu, 29 Nov 2007 22:18:16
Message-Id: 474F366D.6040307@gentoo.org
1 -----BEGIN PGP SIGNED MESSAGE-----
2 Hash: SHA1
3
4 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
5 Gentoo Linux Security Advisory [ERRATA UPDATE] GLSA 200711-20:04
6 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
7 http://security.gentoo.org/
8 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
9
10 Severity: Normal
11 Title: Pioneers: Multiple Denials of Service
12 Date: November 14, 2007
13 Updated: November 29, 2007
14 Bugs: #198807
15 ID: 200711-20:04
16
17 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
18
19 Errata
20 ======
21
22 The fixed ebuild proposed in the original version of this Security
23 Advisory did not address all the vulnerabilities of the Pioneers package.
24 All users of the Pioneers package should upgrade to
25 games-board/pioneers-0.11.3-r1.
26
27 The corrected sections appear below.
28
29 Synopsis
30 ========
31
32 Two Denial of Service vulnerabilities were discovered in Pioneers.
33
34
35 Affected packages
36 =================
37
38 -------------------------------------------------------------------
39 Package / Vulnerable / Unaffected
40 -------------------------------------------------------------------
41 1 games-board/pioneers < 0.11.3-r1 >= 0.11.3-r1
42
43 Description
44 ===========
45
46 Roland Clobus discovered that the Pioneers server may free sessions
47 objects while they are still in use, resulting in access to invalid
48 memory zones (CVE-2007-5933). Bas Wijnen discovered an error when
49 closing connections which can lead to a failed assertion
50 (CVE-2007-6010).
51
52 Resolution
53 ==========
54
55 All Pioneers users should upgrade to the latest version:
56
57 # emerge --sync
58 # emerge --ask --oneshot --verbose ">=games-board/pioneers-0.11.3-r1"
59
60 References
61 ==========
62
63 [ 1 ] CVE-2007-5933
64 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5933
65 [ 2 ] CVE-2007-6010
66 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6010
67
68 Availability
69 ============
70
71 This GLSA and any updates to it are available for viewing at
72 the Gentoo Security Website:
73
74 http://security.gentoo.org/glsa/glsa-200711-20.xml
75
76 Concerns?
77 =========
78
79 Security is a primary focus of Gentoo Linux and ensuring the
80 confidentiality and security of our users machines is of utmost
81 importance to us. Any security concerns should be addressed to
82 security@g.o or alternatively, you may file a bug at
83 http://bugs.gentoo.org.
84
85 License
86 =======
87
88 Copyright 2007 Gentoo Foundation, Inc; referenced text
89 belongs to its owner(s).
90
91 The contents of this document are licensed under the
92 Creative Commons - Attribution / Share Alike license.
93
94 http://creativecommons.org/licenses/by-sa/2.5
95 -----BEGIN PGP SIGNATURE-----
96 Version: GnuPG v1.4.7 (GNU/Linux)
97 Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
98
99 iD8DBQFHTzZsuhJ+ozIKI5gRAnJYAJ9jW6VCcb5CvFI97X2VA7P1d7cBxwCgmQ+d
100 7f7PJ5k2jxWQP1SJCzhkhTY=
101 =IRg0
102 -----END PGP SIGNATURE-----
103 --
104 gentoo-announce@g.o mailing list