Gentoo Archives: gentoo-announce

From: Thomas Deutschmann <whissi@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201909-04 ] Apache: Multiple vulnerabilities
Date: Fri, 06 Sep 2019 16:21:04
Message-Id: cc0f4b3a-1a28-5903-432c-6eccef0abac8@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201909-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Apache: Multiple vulnerabilities
     Date: September 06, 2019
     Bugs: #692172
       ID: 201909-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Apache, the worst of which
could result in a Denial of Service condition.

Background
==========

The Apache HTTP server is one of the most popular web servers on the
Internet.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-servers/apache           < 2.4.41                  >= 2.4.41

Description
===========

Multiple vulnerabilities have been discovered in Apache. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Apache users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/apache-2.4.41"

References
==========

[ 1 ] CVE-2019-10081
      https://nvd.nist.gov/vuln/detail/CVE-2019-10081
[ 2 ] CVE-2019-10082
      https://nvd.nist.gov/vuln/detail/CVE-2019-10082
[ 3 ] CVE-2019-10092
      https://nvd.nist.gov/vuln/detail/CVE-2019-10092
[ 4 ] CVE-2019-10097
      https://nvd.nist.gov/vuln/detail/CVE-2019-10097
[ 5 ] CVE-2019-10098
      https://nvd.nist.gov/vuln/detail/CVE-2019-10098
[ 6 ] CVE-2019-9517
      https://nvd.nist.gov/vuln/detail/CVE-2019-9517

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201909-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2019 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature