Gentoo Archives: gentoo-announce

From: "Christopher Díaz Riveros" <chrisadr@g.o>
To: gentoo-announce@l.g.o
Subject: [gentoo-announce] [ GLSA 201711-13 ] Adobe Flash Player: Multiple vulnerabilities
Date: Sun, 19 Nov 2017 20:27:40
Message-Id: 1511123169.29347.46.camel@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201711-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Adobe Flash Player: Multiple vulnerabilities
     Date: November 19, 2017
     Bugs: #637630
       ID: 201711-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Adobe Flash Player, the
worst of which allows remote attackers to execute arbitrary code.

Background
==========

The Adobe Flash Player is a renderer for the SWF file format, which is
commonly used to provide interactive websites.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-plugins/adobe-flash    < 27.0.0.187            >= 27.0.0.187 

Description
===========

Multiple vulnerabilities have been discovered in Adobe Flash Player.
Please review the referenced CVE identifiers and Adobe Security
Bulletin for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Adobe Flash Player users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=www-plugins/adobe-flash-27.0.0.187"

References
==========

[ 1 ] Adobe Security Bulletin
      https://helpx.adobe.com/security/products/flash-player/apsb17-33.
html
[ 2 ] CVE-2017-11213
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11213
[ 3 ] CVE-2017-11215
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11215
[ 4 ] CVE-2017-11225
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11225
[ 5 ] CVE-2017-3112
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-3112
[ 6 ] CVE-2017-3114
      https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-3114

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201711-13

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature