Gentoo Archives: gentoo-binhost-autobuilds

From: binhost@××××××××××××××××××××××××.org
To: gentoo-binhost-autobuilds@l.g.o
Subject: [gentoo-binhost-autobuilds] [binhost amd64-default-17.1] Update succeeded
Date: Tue, 13 Dec 2022 10:19:51
Message-Id: 20221213101947.06CF526808B@demeter.amd64.dev.gentoo.org
1 Binhost amd64-default-17.1 update succeeded
2
3
4 Spawning container binhost-amd64-x86-64 on /var/lib/machines/binhost-amd64-x86-64.
5 Press ^] three times within 1s to kill container.
6
7 * IMPORTANT: 21 news items need reading for repository 'gentoo'.
8 * Use eselect news read to view new items.
9
10 Calculating dependencies
11 * IMPORTANT: 21 news items need reading for repository 'gentoo'.
12 * Use eselect news read to view new items.
13
14 . ... done!
15
16 !!! Multiple package instances within a single package slot have been pulled
17 !!! into the dependency graph, resulting in a slot conflict:
18
19 dev-qt/qtcore:5
20
21 (dev-qt/qtcore-5.15.7-1:5/5.15.7::gentoo, binary scheduled for merge) USE="icu systemd -debug -old-kernel -test" ABI_X86="(64)" pulled in by
22 dev-qt/qtcore:5/5.15.7= required by (sci-visualization/gnuplot-5.4.4-2:0/0::gentoo, binary scheduled for merge) USE="X cairo gd qt5 readline wxwidgets (-aqua) -bitmap -doc -examples -ggi -latex -libcaca -libcerf -lua -regis" ABI_X86="(64)" LUA_SINGLE_TARGET="lua5-1 -lua5-3 -lua5-4"
23 ^^^^^^^^^^
24 =dev-qt/qtcore-5.15.7* required by (dev-qt/qtdeclarative-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
25 ^ ^^^^^^^
26 (and 33 more with the same problems)
27
28 (dev-qt/qtcore-5.15.5-r3-2:5/5.15.5::gentoo, installed) USE="icu systemd -debug -old-kernel -test" ABI_X86="(64)" pulled in by
29 >=dev-qt/qtcore-5.15.5:5/5.15.5= required by (kde-frameworks/kxmlgui-5.99.0-1:5/5.99::gentoo, installed) USE="-debug -designer -doc -test" ABI_X86="(64)"
30 ^^^^^^^^^^
31 =dev-qt/qtcore-5.15.5*:5/5.15.5= required by (dev-qt/qttest-5.15.5-1:5/5.15::gentoo, installed) USE="-debug -test" ABI_X86="(64)"
32 ^ ^^^^^^^^^^^^^^^^^
33 (and 6 more with the same problems)
34
35 dev-qt/qtgui:5
36
37 (dev-qt/qtgui-5.15.7:5/5.15.7::gentoo, ebuild scheduled for merge) USE="X dbus egl jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -linuxfb -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)" pulled in by
38 dev-qt/qtgui:5/5.15.7= required by (sci-visualization/gnuplot-5.4.4-2:0/0::gentoo, binary scheduled for merge) USE="X cairo gd qt5 readline wxwidgets (-aqua) -bitmap -doc -examples -ggi -latex -libcaca -libcerf -lua -regis" ABI_X86="(64)" LUA_SINGLE_TARGET="lua5-1 -lua5-3 -lua5-4"
39 ^^^^^^^^^^
40 =dev-qt/qtgui-5.15.7*:5=[png] required by (dev-qt/designer-5.15.7:5/5.15::gentoo, ebuild scheduled for merge) USE="declarative -debug -test" ABI_X86="(64)"
41 ^ ^^^^^^^^^^
42 (and 16 more with the same problems)
43
44 (dev-qt/qtgui-5.15.5-r2-1:5/5.15.5::gentoo, installed) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -linuxfb -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)" pulled in by
45 =dev-qt/qtgui-5.15.5*:5/5.15.5=[-gles2-only,png,X] required by (dev-qt/qtwidgets-5.15.5-r1-1:5/5.15::gentoo, installed) USE="X dbus gtk png -debug -gles2-only -test" ABI_X86="(64)"
46 ^ ^^^^^^^^^^^^^^^^^
47 >=dev-qt/qtgui-5.15.5:5/5.15.5=[-gles2-only] required by (media-gfx/krita-5.1.1-3:5/5::gentoo, installed) USE="gif gsl mypaint-brush-engine pdf raw -color-management -debug -fftw -heif -jpegxl -openexr -qtmedia -test -webp" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_10 -python3_11 -python3_8 -python3_9"
48 ^^^^^^^^^^
49 (and 7 more with the same problems)
50
51 dev-qt/qtdbus:5
52
53 (dev-qt/qtdbus-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
54 =dev-qt/qtdbus-5.15.7* required by (dev-qt/qtbluetooth-5.15.7:5/5.15::gentoo, ebuild scheduled for merge) USE="qml -debug -test" ABI_X86="(64)"
55 ^ ^^^^^^^
56 (and 4 more with the same problem)
57
58 (dev-qt/qtdbus-5.15.5-r1-1:5/5.15::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
59 =dev-qt/qtdbus-5.15.5* required by (dev-qt/qtwidgets-5.15.5-r1-1:5/5.15::gentoo, installed) USE="X dbus gtk png -debug -gles2-only -test" ABI_X86="(64)"
60 ^ ^^^^^^^
61 (and 1 more with the same problem)
62
63 dev-qt/qtdeclarative:5
64
65 (dev-qt/qtdeclarative-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)" pulled in by
66 =dev-qt/qtdeclarative-5.15.7* required by (dev-qt/qtwebengine-5.15.7_p20221122:5/5.15::gentoo, ebuild scheduled for merge) USE="alsa bindist jumbo-build system-ffmpeg system-icu widgets -debug -designer -geolocation -kerberos -pulseaudio -screencast -test" ABI_X86="(64)"
67 ^ ^^^^^^^
68 (and 14 more with the same problem)
69
70 (dev-qt/qtdeclarative-5.15.5-4:5/5.15::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)" pulled in by
71 =dev-qt/qtdeclarative-5.15.5*:5/5.15= required by (dev-qt/qtwayland-5.15.5-r1-1:5/5.15.5::gentoo, installed) USE="X -debug -test -vulkan" ABI_X86="(64)"
72 ^ ^^^^^^^^^^^^^^^
73
74 dev-qt/qtnetwork:5
75
76 (dev-qt/qtnetwork-5.15.7:5/5.15::gentoo, ebuild scheduled for merge) USE="ssl -connman -debug -gssapi -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
77 =dev-qt/qtnetwork-5.15.7* required by (dev-qt/designer-5.15.7:5/5.15::gentoo, ebuild scheduled for merge) USE="declarative -debug -test" ABI_X86="(64)"
78 ^ ^^^^^^^
79 (and 7 more with the same problem)
80
81 (dev-qt/qtnetwork-5.15.5-1:5/5.15::gentoo, installed) USE="ssl -connman -debug -gssapi -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
82 =dev-qt/qtnetwork-5.15.5* required by (dev-qt/qtdeclarative-5.15.5-4:5/5.15::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
83 ^ ^^^^^^^
84
85 dev-qt/qttest:5
86
87 (dev-qt/qttest-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
88 =dev-qt/qttest-5.15.7* required by (dev-qt/qtdeclarative-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
89 ^ ^^^^^^^
90
91 (dev-qt/qttest-5.15.5-1:5/5.15::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
92 =dev-qt/qttest-5.15.5* required by (dev-qt/qtdeclarative-5.15.5-4:5/5.15::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
93 ^ ^^^^^^^
94
95 dev-qt/qtwidgets:5
96
97 (dev-qt/qtwidgets-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="X dbus gtk png -debug -gles2-only -test" ABI_X86="(64)" pulled in by
98 =dev-qt/qtwidgets-5.15.7*[-gles2-only] required by (dev-qt/qtdeclarative-5.15.7-1:5/5.15::gentoo, binary scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
99 ^ ^^^^^^^
100 (and 10 more with the same problem)
101
102 (dev-qt/qtwidgets-5.15.5-r1-1:5/5.15::gentoo, installed) USE="X dbus gtk png -debug -gles2-only -test" ABI_X86="(64)" pulled in by
103 =dev-qt/qtwidgets-5.15.5*[-gles2-only] required by (dev-qt/qtdeclarative-5.15.5-4:5/5.15::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
104 ^ ^^^^^^^
105
106 NOTE: Use the '--verbose-conflicts' option to display parents omitted above
107
108 It may be possible to solve this problem by using package.mask to
109 prevent one of those packages from being selected. However, it is also
110 possible that conflicting dependencies exist such that they are
111 impossible to satisfy simultaneously. If such a conflict exists in
112 the dependencies of two different packages, then those packages can
113 not be installed simultaneously.
114
115 For more information, see MASKED PACKAGES section in the emerge man
116 page or refer to the Gentoo Handbook.
117
118
119 !!! The following binary packages have been ignored due to changed dependencies:
120
121 media-libs/gst-plugins-base-1.20.3::gentoo
122 media-libs/gst-plugins-bad-1.20.3::gentoo
123
124 NOTE: The --binpkg-changed-deps=n option will prevent emerge
125 from ignoring these binary packages if possible.
126 Using --binpkg-changed-deps=y will silence this warning.
127
128 emerge: there are no ebuilds built with USE flags to satisfy "media-video/ffmpeg[encode,libass,sdl,X]".
129 !!! One of the following packages is required to complete your request:
130 - media-video/ffmpeg-4.4.3::gentoo (Change USE: +libass)
131 (dependency required by "kde-apps/kdenlive-22.08.3::gentoo" [ebuild])
132 (dependency required by "kde-apps/kdemultimedia-meta-22.08.3::gentoo" [ebuild])
133 (dependency required by "kde-apps/kde-apps-meta-22.08.3::gentoo[multimedia]" [ebuild])
134 (dependency required by "@selected" [set])
135 (dependency required by "@world" [argument])
136
137 * Always study the list of packages to be cleaned for any obvious
138 * mistakes. Packages that are part of the world set will always
139 * be kept. They can be manually added to this set with
140 * `emerge --noreplace <atom>`. Packages that are listed in
141 * package.provided (see portage(5)) will be removed by
142 * depclean, even if they are part of the world set.
143 *
144 * As a safety measure, depclean will not remove any packages
145 * unless *all* required dependencies have been resolved. As a
146 * consequence of this, it often becomes necessary to run
147 * `emerge --update --newuse --deep @world` prior to depclean.
148
149 Calculating dependencies .. ... done!
150 >>> No packages selected for removal by depclean
151 >>> To see reverse dependencies, use --verbose
152 Packages installed: 1409
153 Packages in world: 34
154 Packages in system: 43
155 Required packages: 1409
156 Number removed: 0
157 >>> Building file list for packages cleaning...
158 >>> Cleaning binary packages...
159 [ 85.2 M ] dev-lang/rust-1.64.0-r1
160 [ 139.6 K ] dev-python/requests-2.28.1
161 [ 150.8 K ] dev-util/ninja-1.11.1-r2
162 [ 83.5 M ] media-gfx/krita-5.1.1
163 [ 17.8 K ] virtual/rust-1.64.0
164
165
166 Emaint: fix binhost [<=> ]
167 Emaint: fix binhost 100% [============================================>]
168 Emaint: fix binhost 100% [============================================>]
169
170 [ 12.6 K ] Packages Index
171 ===========
172 [ 169.1 M ] Total space from 5 files were freed in the packages directory
173 Container binhost-amd64-x86-64 exited successfully.
174 Spawning container binhost-amd64-x86-64-gnome on /var/lib/machines/binhost-amd64-x86-64-gnome.
175 Press ^] three times within 1s to kill container.
176
177 * IMPORTANT: 4 config files in '/etc' need updating.
178 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
179 * sections of the emerge man page to learn how to update config files.
180
181 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
182 * Use eselect news read to view new items.
183
184 Calculating dependencies
185 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
186 * Use eselect news read to view new items.
187
188 ... .... done!
189 >>> Verifying ebuild manifests
190 >>> Jobs: 0 of 1 complete, 1 running Load avg: 12.0, 18.6, 23.9
191 >>> Emerging (1 of 1) sys-apps/bubblewrap-0.7.0::gentoo
192 >>> Jobs: 0 of 1 complete, 1 running Load avg: 12.0, 18.6, 23.9
193 >>> Installing (1 of 1) sys-apps/bubblewrap-0.7.0::gentoo
194 >>> Jobs: 0 of 1 complete, 1 running Load avg: 13.6, 18.7, 23.9
195 >>> Jobs: 0 of 1 complete Load avg: 13.6, 18.7, 23.9
196 >>> Jobs: 1 of 1 complete Load avg: 14.4, 18.8, 23.9
197
198 * Messages for package sys-apps/bubblewrap-0.7.0:
199 * Unable to find kernel sources at /usr/src/linux
200 * Unable to calculate Linux Kernel version for build, attempting to use running version
201
202
203
204 * GNU info directory index is up-to-date.
205
206 * IMPORTANT: 4 config files in '/etc' need updating.
207 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
208 * sections of the emerge man page to learn how to update config files.
209
210 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
211 * Use eselect news read to view new items.
212
213 * After world updates, it is important to remove obsolete packages with
214 * emerge --depclean. Refer to `man emerge` for more information.
215
216 * Always study the list of packages to be cleaned for any obvious
217 * mistakes. Packages that are part of the world set will always
218 * be kept. They can be manually added to this set with
219 * `emerge --noreplace <atom>`. Packages that are listed in
220 * package.provided (see portage(5)) will be removed by
221 * depclean, even if they are part of the world set.
222 *
223 * As a safety measure, depclean will not remove any packages
224 * unless *all* required dependencies have been resolved. As a
225 * consequence of this, it often becomes necessary to run
226 * `emerge --update --newuse --deep @world` prior to depclean.
227
228 Calculating dependencies . ... done!
229 >>> No packages selected for removal by depclean
230 >>> To see reverse dependencies, use --verbose
231 Packages installed: 1140
232 Packages in world: 27
233 Packages in system: 43
234 Required packages: 1140
235 Number removed: 0
236 Container binhost-amd64-x86-64-gnome exited successfully.
237
238
239
240 Full build log at /root/.tmp-binhost-amd64-default-17.1-update-1670926621