On Fri, 2013-12-13 at 20:51 -0800, Matt Turner wrote: > On Fri, Dec 13, 2013 at 7:07 PM, Brian Dolbec wrote: > > Use the new configured snapshot_name and portdir settings > > Use the portdir setting rather than hard-coded path > > --- > > catalyst | 14 +++++++++----- > > modules/generic_stage_target.py | 6 ++++-- > > modules/snapshot_target.py | 14 +++++++++----- > > modules/tinderbox_target.py | 4 ++-- > > 4 files changed, 24 insertions(+), 14 deletions(-) > > > > diff --git a/catalyst b/catalyst > > index ba26f3c..19ec77e 100755 > > --- a/catalyst > > +++ b/catalyst > > @@ -61,11 +61,15 @@ def parse_config(myconfig): > > myconf={} > > config_file="" > > > > - confdefaults={ "storedir":"/var/tmp/catalyst",\ > > - "sharedir":"/usr/share/catalyst","distdir":"/usr/portage/distfiles",\ > > - "portdir":"/usr/portage","options":"",\ > > - "snapshot_cache":"/var/tmp/catalyst/snapshot_cache",\ > > - "hash_function":"crc32"} > > + confdefaults={ > > + "hash_function": "crc32", > > + "portdir": "/usr/portage", > > + "repo_name": "portage", > > + "sharedir": "/usr/lib/catalyst", > > + "snapshot_name": "portage-", > > + "snapshot_cache": "/var/tmp/catalyst/snapshot_cache", > > + "storedir": "/var/tmp/catalyst", > > + } > > I agree that adding a key:value to store "portage-" seems unnecessary. > I don't think we should do this unless someone has a compelling > reason. > Reasons for the change: 1) it is bad design to have things hard-coded in many places throughout the code. 2) this makes it one easy to edit and central place to change it. 3) I feel the name is incorrect and I intend to lobby for it to be changed during the tree move from /usr/portage to the new location somewhere in /var (bikeshedding likely to continue on the final location once catalyst is actually capable of producing stages with and for the moved tree. Which is _the_ reason I got started coding on catalyst in the first place.). I regard portage as the name of the package manager and not the tree, the repo_name is "gentoo", not "portage". Plus it is likely to be less confusing for noobs first installing gentoo that get confused between portage the package manager and portage the tree. P.S. plus you didn't have to code it. It has been done for you ;) > Also, we lost "options" here. Is this intentional or consequential? > likely another rebase error. I did revamp the options system which had duplications all through the code. But I don't believe that should be showing up here. > > -- > > 1.8.3.2 > > > >