Gentoo Archives: gentoo-commits

From: "Robert Buchholz (rbu)" <rbu@g.o>
To: gentoo-commits@l.g.o
Subject: [gentoo-commits] gentoo commit in xml/htdocs/security/en/glsa: glsa-200901-09.xml
Date: Tue, 13 Jan 2009 12:19:39
rbu         09/01/13 12:19:36

  Added:                glsa-200901-09.xml
  GLSA 200901-09

Revision  Changes    Path
1.1                  xml/htdocs/security/en/glsa/glsa-200901-09.xml

file :

Index: glsa-200901-09.xml
<?xml version="1.0" encoding="utf-8"?>
<?xml-stylesheet href="/xsl/glsa.xsl" type="text/xsl"?>
<?xml-stylesheet href="/xsl/guide.xsl" type="text/xsl"?>

<glsa id="200901-09">
  <title>Adobe Reader: User-assisted execution of arbitrary code</title>
    Adobe Reader is vulnerable to execution of arbitrary code.
  <product type="ebuild">acroread</product>
  <announced>January 13, 2009</announced>
  <revised>January 13, 2009: 01</revised>
    <package name="app-text/acroread" auto="yes" arch="*">
      <unaffected range="ge">8.1.3</unaffected>
      <vulnerable range="lt">8.1.3</vulnerable>
    Adobe Reader (formerly Adobe Acrobat Reader) is a closed-source PDF
    An unspecified vulnerability can be triggered by a malformed PDF
    document, as demonstrated by 2008-HI2.pdf (CVE-2008-2549).
    Peter Vreugdenhil, Dyon Balding, Will Dormann, Damian Frizza, and Greg
    MacManus reported a stack-based buffer overflow in the util.printf
    JavaScript function that incorrectly handles the format string argument
    Greg MacManus of iDefense Labs reported an array index error that can
    be leveraged for an out-of-bounds write, related to parsing of Type 1
    fonts (CVE-2008-4812).
    Javier Vicente Vallejo and Peter Vregdenhil, via Zero Day Initiative,
    reported multiple unspecified memory corruption vulnerabilities
    Thomas Garnier of SkyRecon Systems reported an unspecified
    vulnerability in a JavaScript method, related to an "input validation
    issue" (CVE-2008-4814).
    Josh Bressers of Red Hat reported an untrusted search path
    vulnerability (CVE-2008-4815).
    Peter Vreugdenhil reported through iDefense that the Download Manager
    can trigger a heap corruption via calls to the AcroJS function
  <impact type="normal">
    A remote attacker could entice a user to open a specially crafted PDF
    document, and local attackers could entice a user to run acroread from
    an untrusted working directory. Both might result in the execution of
    arbitrary code with the privileges of the user running the application,
    or a Denial of Service.
    There is no known workaround at this time.
    All Adobe Reader users should upgrade to the latest version:
    # emerge --sync
    # emerge --ask --oneshot --verbose &quot;&gt;=app-text/acroread-8.1.3&quot;</code>
    <uri link="">CVE-2008-2549</uri>
    <uri link="">CVE-2008-2992</uri>
    <uri link="">CVE-2008-4812</uri>
    <uri link="">CVE-2008-4813</uri>
    <uri link="">CVE-2008-4814</uri>
    <uri link="">CVE-2008-4815</uri>
    <uri link="">CVE-2008-4817</uri>
  <metadata tag="requester" timestamp="Wed, 26 Nov 2008 18:53:29 +0000">
  <metadata tag="submitter" timestamp="Wed, 26 Nov 2008 20:51:39 +0000">
  <metadata tag="bugReady" timestamp="Wed, 26 Nov 2008 20:51:48 +0000">