Gentoo Archives: gentoo-commits

From: "Tobias Heinlein (keytoaster)" <keytoaster@g.o>
To: gentoo-commits@l.g.o
Subject: [gentoo-commits] gentoo commit in xml/htdocs/security/en/glsa: glsa-201206-13.xml
Date: Thu, 21 Jun 2012 20:41:07
keytoaster    12/06/21 20:40:51

  Added:                glsa-201206-13.xml
  GLSA 201206-13

Revision  Changes    Path
1.1                  xml/htdocs/security/en/glsa/glsa-201206-13.xml

file :

Index: glsa-201206-13.xml
<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="/xsl/glsa.xsl"?>
<?xml-stylesheet type="text/xsl" href="/xsl/guide.xsl"?>
<glsa id="201206-13">
  <title>Mono: Multiple vulnerabilities</title>
  <synopsis>Multiple vulnerabilities were found in Mono, the worst of which
    allowing for the remote execution of arbitrary code.
  <product type="ebuild">mono mono-debugger</product>
  <announced>June 21, 2012</announced>
  <revised>June 21, 2012: 1</revised>
  <access>local, remote</access>
    <package name="dev-util/mono-debugger" auto="yes" arch="*">
      <unaffected range="ge">2.8.1-r1</unaffected>
      <vulnerable range="lt">2.8.1-r1</vulnerable>
    <package name="dev-lang/mono" auto="yes" arch="*">
      <unaffected range="ge">2.10.2-r1</unaffected>
      <vulnerable range="lt">2.10.2-r1</vulnerable>
    <p>Mono is an open source implementation of Microsoft's .NET Framework.</p>
    <p>Multiple vulnerabilities have been discovered in Mono and Mono debugger.
      Please review the CVE identifiers referenced below for details.
  <impact type="high">
    <p>A remote attacker could execute arbitrary code, bypass general
      constraints, obtain the source code for .aspx applications, obtain other
      sensitive information, cause a Denial of Service, modify internal data
      structures, or corrupt the internal state of the security manager.
    <p>A local attacker could entice a user into running Mono debugger in a
      directory containing a specially crafted library file to execute
      arbitrary code with the privileges of the user running Mono debugger.
    <p>A context-dependant attacker could bypass the authentication mechanism
      provided by the XML Signature specification.
    <p>There is no known workaround at this time.</p>
    <p>All Mono debugger users should upgrade to the latest version:</p>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=dev-util/mono-debugger-2.8.1-r1"
    <p>All Mono users should upgrade to the latest version:</p>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=dev-lang/mono-2.10.2-r1"
    <uri link="">CVE-2009-0217</uri>
    <uri link="">CVE-2010-3332</uri>
    <uri link="">CVE-2010-3369</uri>
    <uri link="">CVE-2010-4159</uri>
    <uri link="">CVE-2010-4225</uri>
    <uri link="">CVE-2010-4254</uri>
    <uri link="">CVE-2011-0989</uri>
    <uri link="">CVE-2011-0990</uri>
    <uri link="">CVE-2011-0991</uri>
    <uri link="">CVE-2011-0992</uri>
  <metadata timestamp="Sat, 08 Oct 2011 22:43:20 +0000" tag="requester">craig</metadata>
  <metadata timestamp="Thu, 21 Jun 2012 20:40:21 +0000" tag="submitter">