Gentoo Archives: gentoo-commits

From: Lars Wendler <polynomial-c@g.o>
To: gentoo-commits@l.g.o
Subject: [gentoo-commits] repo/gentoo:master commit in: sys-apps/man-db/
Date: Thu, 31 Jan 2019 23:11:08
Message-Id: 1548976256.63dbb517cda5ac93a69a484c0444b8c6d3952a91.polynomial-c@gentoo
commit:     63dbb517cda5ac93a69a484c0444b8c6d3952a91
Author:     Lars Wendler <polynomial-c <AT> gentoo <DOT> org>
AuthorDate: Thu Jan 31 23:10:56 2019 +0000
Commit:     Lars Wendler <polynomial-c <AT> gentoo <DOT> org>
CommitDate: Thu Jan 31 23:10:56 2019 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=63dbb517

sys-apps/man-db: Replaced version_is_at_least with ver_test

Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c <AT> gentoo.org>

 sys-apps/man-db/man-db-2.8.5.ebuild | 2 +-
 sys-apps/man-db/man-db-9999.ebuild  | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/sys-apps/man-db/man-db-2.8.5.ebuild b/sys-apps/man-db/man-db-2.8.5.ebuild
index fc34d010327..6935f3bcada 100644
--- a/sys-apps/man-db/man-db-2.8.5.ebuild
+++ b/sys-apps/man-db/man-db-2.8.5.ebuild
@@ -92,7 +92,7 @@ pkg_preinst() {
 	local _replacing_version=
 	local _setgid_vuln=0
 	for _replacing_version in ${REPLACING_VERSIONS}; do
-		if version_is_at_least '2.7.6.1-r2' "${_replacing_version}"; then
+		if ver_test '2.7.6.1-r2' -gt "${_replacing_version}"; then
 			debug-print "Skipping security bug #602588 ... existing installation (${_replacing_version}) should not be affected!"
 		else
 			_setgid_vuln=1

diff --git a/sys-apps/man-db/man-db-9999.ebuild b/sys-apps/man-db/man-db-9999.ebuild
index fc34d010327..6935f3bcada 100644
--- a/sys-apps/man-db/man-db-9999.ebuild
+++ b/sys-apps/man-db/man-db-9999.ebuild
@@ -92,7 +92,7 @@ pkg_preinst() {
 	local _replacing_version=
 	local _setgid_vuln=0
 	for _replacing_version in ${REPLACING_VERSIONS}; do
-		if version_is_at_least '2.7.6.1-r2' "${_replacing_version}"; then
+		if ver_test '2.7.6.1-r2' -gt "${_replacing_version}"; then
 			debug-print "Skipping security bug #602588 ... existing installation (${_replacing_version}) should not be affected!"
 		else
 			_setgid_vuln=1