Gentoo Archives: gentoo-desktop

From: "E. Liddell" <ejlddll@××××××××××.com>
To: gentoo-desktop@l.g.o
Subject: Re: [gentoo-desktop] Re: kde-sunset: qt-meta-3.3.8b-r2 build failure with libpng < 1.5
Date: Wed, 12 Oct 2011 00:03:46
Message-Id: 20111011195059.144ec653@akio.homenetwork
In Reply to: [gentoo-desktop] Re: kde-sunset: qt-meta-3.3.8b-r2 build failure with libpng < 1.5 by Duncan <>
On Tue, 11 Oct 2011 23:00:26 +0000 (UTC)
Duncan <1i5t5.duncan@×××.net> wrote:

> However, from what I've read, this is one of the things the trinity folks > are-dealing/have-dealt with since hal is pretty clearly toast at this > point. Since I've not even touched kde-sunset overlay, I've no idea if > there's builds for their releases or not, but if so, I'd presume they'd > be 3.5.11+. So you may wish to try those (if available) and see what > happens.
Trinity has released 3.5.12 and is working on 3.5.13. Serghei Amelian was working on ebuilds; his Github repository can be found at I'm not sure how current these files are, but AFAIK they are the most complete available at the moment. (There are a couple of other ebuild initiatives, but the last time I checked, they hadn't gotten beyond kdebase and kdelibs yet.) However, Trinity has not replaced hal yet, so installing it won't fix anyone's automouting problems.