Gentoo Archives: gentoo-desktop

From: "Nelson
To: gentoo-desktop@l.g.o
Subject: RE: [gentoo-desktop] dbus upgrade problems
Date: Fri, 02 Feb 2007 10:10:19
In Reply to: Re: [gentoo-desktop] dbus upgrade problems by Donnie Berkholz
> -----Original Message----- > From: Donnie Berkholz [mailto:dberkholz@g.o] > Sent: 02 February 2007 01:24 > To: gentoo-desktop@l.g.o > Subject: Re: [gentoo-desktop] dbus upgrade problems > > > Lindsay Haisley wrote: > > I'm trying to do an upgrade on my Gentoo desktop system. > One of the pieces > > that's in need of upgrading is dbus, from v0.62-r2 to > v1.0.2, and in fact the > > former blocks the latter so I can't upgrade anything else > until I do the dbus > > upgrade. revdep-rebuild indicates that dozens of packages > are broken by the > > dbus upgrade! > > > > The most important of these packages for my work is > evolution, which is flakey > > at best and drives me crazy at times, but I depend on it so > I'm careful to not > > do anything to disable it. So I upgraded dbus, and then > tried to upgrade > > evolution, but the ebuild fails with the following: > > I downversioned dbus to where it was before and things are > working normally > > again, but I'm stuck until I can figure out how to > re-emerge evolution if I > > upgrade dbus. Can anyone advise me? > > Evolution could get that dependency from another library it > uses, which > in turn uses dbus. You really need to run the full revdep-rebuild. > > Thanks, > Donnie > >
Another vote here for revdep-rebuild. It fixed all my issues after the dbus upgrade. There are a *lot* of packages that will need rebuilt but I suggest just leaving it overnight to fix everything (it's what I did). -- djn -- gentoo-desktop@g.o mailing list