Gentoo Archives: gentoo-dev

From: Joshua Kinard <kumba@g.o>
To: gentoo-dev@l.g.o
Cc: base-system@g.o
Subject: Re: [gentoo-dev] [PATCH eutils] Introduce has_iuse() for IUSE checks.
Date: Tue, 13 Sep 2011 10:40:46
In Reply to: Re: [gentoo-dev] [PATCH eutils] Introduce has_iuse() for IUSE checks. by "Michał Górny"
On 09/13/2011 06:29, Michał Górny wrote:

> On Tue, 13 Sep 2011 12:21:31 +0200 > Michał Górny <mgorny@g.o> wrote: > >> +# @FUNCTION: has_iuse > > Ideas for a better name will be appreciated.
'in_iuse' or 'iuse_contains'? if $(in_iuse foobar); do $(cake) fi or if $(iuse_contains foobar); do $(cake) fi Thinking from just a general pronunciation perspective, though. Assuming someone reads that as "If in eye-use..." or "If eye-use contains ...". 'has_iuse' Almost reads as "has issues ...", hence, "if has issues; then ($cake) && $(grief_counseling) ...". -- Joshua Kinard Gentoo/MIPS kumba@g.o 4096R/D25D95E3 2011-03-28 "The past tempts us, the present confuses us, the future frightens us. And our lives slip away, moment by moment, lost in that vast, terrible in-between." --Emperor Turhan, Centauri Republic


File name MIME type
signature.asc application/pgp-signature