Gentoo Archives: gentoo-dev

From: Enrico Weigelt <weigelt@×××××.de>
To: gentoo developers <gentoo-dev@l.g.o>, gentoo-user <gentoo-user@l.g.o>
Subject: [gentoo-dev] Wrong dependencies to postgresql
Date: Sat, 23 Dec 2006 23:00:42
Message-Id: 20061223225446.GA19428@nibiru.local
Hi folks,

since jakub (as always) closes all my bugs, I'll report the issue 
to this list before completely giving up and never ever waste a 
single second on reporting bugs ...

Lots of packages have an wrong/unnecessary dependency to 
postgresql. Three cases:

a) probably traditionally depended on the whole postgresql, maybe 
   since before libpq was an own package. ie. qt, dovecot, ...
   
b) many apps (ie. webapps like bugzilla) have postgresql as dep.,
   although they do not need it to be installed. (ie. bugzilla does 
   not have to do anything directly w/ postgresql, since it uses 
   perl-DBD for database access). Of course they maybe want to 
   have access to some postgres database, but this obviously does
   not need an local server.
   

cu
-- 
---------------------------------------------------------------------
 Enrico Weigelt    ==   metux IT service - http://www.metux.de/
---------------------------------------------------------------------
 Please visit the OpenSource QM Taskforce:
 	http://wiki.metux.de/public/OpenSource_QM_Taskforce
 Patches / Fixes for a lot dozens of packages in dozens of versions:
	http://patches.metux.de/
---------------------------------------------------------------------
-- 
gentoo-dev@g.o mailing list

Replies