Gentoo Archives: gentoo-dev

From: Chris Houser <chouser@g.o>
To: gentoo-dev@××××××××××.org
Subject: [gentoo-dev] segfault during bootstrap (rc6-r9)
Date: Sun, 23 Sep 2001 21:10:49
I have been having problems getting build-ix86-1.0_rc6-r9.tbz2 to
bootstrap, using portage-1.6.9.  During the 'merge' portion of the glibc
emerge, I would get this output:

    >>> Completed installing into /var/tmp/portage/glibc-2.2.4-r1/image/

    Saving ld-linux,libc6 and libpthread
    /bin/cp: cannot create regular file `/tmp/': Text file busy

...and then a segfault.  I tried this a couple times, getting similar or
identical results.

Finally, I decided to manually step through what the bootstrap script

    # USE="build" ebuild /usr/portage/sys-apps/baselayout-1.6.3/baselayout-1.6.3.ebuild merge
    # USE="build" ebuild /usr/portage/sys-devel/binutils-  merge
    # USE="build" ebuild /usr/portage/sys-devel/gcc/gcc-2.95.3-r5.ebuild merge
    # ebuild /usr/portage/sys-libs/glibc/glibc-2.2.4-r1.ebuild merge

...and this seemed to work fine.  I don't know why.  I finished doing
the manual bootstrap, and it seems to be working fine:

    # ebuild /usr/portage/sys-devel/binutils/binutils- merge
    # emerge sys-devel/gcc
    # emerge sys-apps/texinfo

I don't know what was broken before, or why it worked, but I thought I
should at least record what I did.  Hopefully if anyone else sees the
same bootstrap error I did, we'll be able to find a fix.

My machine is now happily working on 'emerge system'.  Thanks to
everyone on IRC that helped me a long the way.



Subject Author
RE: [gentoo-dev] segfault during bootstrap (rc6-r9) Joe DeRosa <derosa@×××××××××.net>