Gentoo Archives: gentoo-dev

From: "Tomáš Chvátal" <scarabeus@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Re: News item announcing as-needed (glep 42 stuff)
Date: Tue, 27 Jul 2010 08:37:03
In Reply to: [gentoo-dev] Re: News item announcing as-needed (glep 42 stuff) by Ryan Hill
Hash: SHA1

Dne 27.7.2010 05:38, Ryan Hill napsal(a):
> Yep. Can I suggest: > > -Wl,--as-needed has been added to the default profile's LDFLAGS. > > This option optimizes the linking process, only linking binaries to > libraries that are trully needed. This way, fewer libraries are loaded > at runtime and fewer packages need to be rebuilt after library updates. > > To take advantage of the new default you can either rebuild world now or just > allow the system to migrate incrementally as it updates. > > Please note that setting LDFLAGS="<your flags>" in your make.conf will > override the profile defaults. If you want to add additional LDFLAGS it is > recommended to use LDFLAGS="${LDFLAGS} <your flags>" instead to avoid this. > > For more information on --as-needed, read [1]. > > [1] > >
I like this. Consider this as the update :] With one simple replace s/trully/truly/ :P Tom -----BEGIN PGP SIGNATURE----- Version: GnuPG v2.0.15 (GNU/Linux) Comment: Using GnuPG with Mozilla - iEYEARECAAYFAkxOmpwACgkQHB6c3gNBRYfiMwCfRWQEheYwNbssCd5qReSSCyKq ACcAoJlm9ag96GEk0Bt3rLLdP1tx8XKv =jZnr -----END PGP SIGNATURE-----