Gentoo Archives: gentoo-dev

From: Alice Ferrazzi <alicef@g.o>
To: gentoo-dev@l.g.o
Cc: Alice Ferrazzi <alicef@g.o>
Subject: [gentoo-dev] [PATCH] kernel-2.eclass: enable eapi6
Date: Wed, 15 Feb 2017 17:37:36
Message-Id: 20170215173715.32146-1-alicef@gentoo.org
After mpagano works on the kernel-2.eclass update,
I think we can move kernel-2.eclass to EAPI6.

---
 eclass/kernel-2.eclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 0c9ce04..351e32c 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -198,7 +198,7 @@ case ${EAPI:-0} in
 	0|1)
 		EXPORT_FUNCTIONS src_{unpack,compile,install,test} \
 			pkg_{setup,preinst,postinst,postrm} ;;
-	2|3|4|5)
+	2|3|4|5|6)
 		EXPORT_FUNCTIONS src_{unpack,prepare,compile,install,test} \
 			pkg_{setup,preinst,postinst,postrm} ;;
 	*) die "${ECLASS}: EAPI ${EAPI} not supported" ;;
-- 
2.7.3

Replies

Subject Author
Re: [gentoo-dev] [PATCH] kernel-2.eclass: enable eapi6 Mike Pagano <mpagano@g.o>