Gentoo Archives: gentoo-dev

From: Gilles Dartiguelongue <eva@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Over using preserve_old_lib, don't do that
Date: Mon, 05 Jul 2010 16:40:43
In Reply to: [gentoo-dev] Over using preserve_old_lib, don't do that by Samuli Suominen
Le vendredi 02 juillet 2010 à 08:51 +0300, Samuli Suominen a écrit :
> I've recently stumbled upon several packages unnecessarily using old > preserve_old_lib feature from eutils.eclass, namely: > > libgnomekbd > libproxy > > And then users hit issues like this: > >
1. How is it different than preserved-libs feature from portage-2.2 ? The issue that I have with you argument is that you encourage breaking user apps at build time instead of leaving the user some time to run revdep-rebuild or any other tool needed when user wishes so. 2. We cannot (and do not in gnome herd) support users who did not complete revdep-rebuild. We help them get out of build problem if possible and if the bug still exists by then, we try to fix it but otherwise it's just closed invalid. -- Gilles Dartiguelongue <eva@g.o> Gentoo


Subject Author
Re: [gentoo-dev] Over using preserve_old_lib, don't do that Mike Auty <ikelos@g.o>