Gentoo Archives: gentoo-dev

From: Donnie Berkholz <dberkholz@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] RFC about another *DEPEND variable
Date: Thu, 21 Sep 2006 14:58:19
In Reply to: Re: [gentoo-dev] RFC about another *DEPEND variable by Mike Frysinger
Mike Frysinger wrote:
> On Thursday 21 September 2006 10:14, Donnie Berkholz wrote: >> Not adding it into the ebuild means that it's impossible to show in >> advance what packages will actually be installed, because you don't know >> whether the sover will bump. > > sometimes you dont know as the ABI bump may be arch or feature specific ... > pathological case i agree ;) > > you would certainly know between the time you merge the new one and unmerge > the old one though ... but now we tread into the territory of "portage should > not unmerge ABI libraries until all consumers have been destroyed" which is > better than the current craptastic situation of "you gotta revdep-rebuild > after the fact with a broken system"
Yes, I agree with you. For example, take expat. The maintainers have refused to allow both versions to exist simultaneously on a system because it apparently causes more breakage than just breaking every app on your system by removing .so.0. Thanks, Donnie -- gentoo-dev@g.o mailing list


Subject Author
Re: [gentoo-dev] RFC about another *DEPEND variable Mike Frysinger <vapier@g.o>