Gentoo Archives: gentoo-dev

From: Carsten Lohrke <carlo@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Fwd: News item: Generation 1 deprecation
Date: Sun, 22 Feb 2009 23:29:36
Message-Id: 200902230029.30719.carlo@gentoo.org
In Reply to: [gentoo-dev] Fwd: News item: Generation 1 deprecation by "Petteri Räty"
1 On Sonntag, 22. Februar 2009, Petteri Räty wrote:
2 > java-check-environment
3
4 Running it, I got the message everything would be fine, but after uninstalling
5 Sun's 1.4 JDK, Portage told me it'll be still needed. So after a bit package
6 masking and uninstalling
7
8 dev-java/sun-jdk:1.4
9 =dev-java/java-sdk-docs-1.4*
10 virtual/jdk:1.4
11 virtual/jre:1.4
12
13 I got
14
15 For more information, see the MASKED PACKAGES section in the emerge
16 man page or refer to the Gentoo Handbook.
17 (dependency required by "dev-java/tomcat-servlet-api-5.5.27" [installed])
18 (dependency required by "dev-util/eclipse-sdk-3.4-r2" [installed])
19 (dependency required by "@world" [argument])
20
21 and after looking at the tomcat-servlet-api ebuild I finally found that
22 setting a java5 use flag and re-emerging the ebuild would be required, et
23 voila...
24
25
26 It's really great that the Java team managed to convert all packages, but I do
27 not call the above procedure user friendly. ;)
28
29
30 Carsten

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] Fwd: News item: Generation 1 deprecation "Petteri Räty" <betelgeuse@g.o>