Gentoo Archives: gentoo-dev

From: Stephen Bennett <spb@g.o>
To: gentoo-dev@l.g.o
Subject: [gentoo-dev] Dependencies on sys-apps/portage
Date: Sun, 10 Dec 2006 01:15:24
Message-Id: 20061210011117.36672693@blashyrk
There are a lot of packages in the tree which DEPEND on some version of
sys-apps/portage, mostly for historical reasons. Try to avoid doing
this in your packages where possible -- if it's a genuine dependency
then obviously it should be there, but if the dep is only in the ebuild
to avoid hitting a bug that was in portage-2.0.49-r3 (for example),
it's unnecessary now. I'm going to be removing some of these redundant
deps.

On which note, the current base profile specifies portage-2.0.51.22 or
later -- can anyone see a reason not to require 2.1? There are a lot of
packages that dep on portage-2.1 for the "wrong" reasons above, which
I'd like to be able to clean up.
-- 
gentoo-dev@g.o mailing list

Replies

Subject Author
[gentoo-dev] Dependencies on system packages Stephen Bennett <spb@g.o>
[gentoo-dev] Re: Dependencies on sys-apps/portage opfer@gentoo.org (Christian Faulhammer)