Gentoo Archives: gentoo-dev

From: Alon Bar-Lev <alonbl@g.o>
To: gentoo-dev@l.g.o
Subject: [gentoo-dev] [Attention] app-crypt/gnupg-2.0.1-r1 - Drop-in replacement to gnupg-1.4
Date: Sat, 09 Dec 2006 16:56:35
Message-Id: 9e0cf0bf0612090853u6752dc2rc09e6bb658c8d918@mail.gmail.com
Hello,

Until now gnupg-1.9/gnupg-2 serieses were installed side-by-site with
gnupg-1.4 series, and actually was depended on the old version.

Starting from gnupg-2.0.1-r1 (masked) app-crypt/gnupg-2.0.1-r1 is
configured to be a drop-in replacement.

It lacks the static use flag, I could not find a simple way to achieve this.
Also ecc patch is not ready yet.

Effected packages which blocks the gnupg-2 series:

gnome:
app-crypt/seahorse-0.8.2

kde:
kde-base/certmanager-3.5.5
kde-base/kdepim-3.5.5

The kde packages should just modify the dependency.
The seahorse package should be checked more deeply, it looks like it
gnupg version dependend.

Anyone who wants to test help testing is welcome to provide feedback.

Best Regards,
Alon Bar-Lev.
-- 
gentoo-dev@g.o mailing list

Replies