Gentoo Archives: gentoo-dev

From: Dale <dalek@××××××××××.net>
To: gentoo-dev@l.g.o
Subject: [gentoo-dev] ERROR: gnome-base/bonobo-1.0.22 failed.
Date: Wed, 02 Nov 2005 17:01:55
Message-Id: 4368EFAA.20609@exceedtech.net
Well, it's me again.  LOL

I am trying to successfully finish a revdep-rebuild and am having a bit
of fun with it.  It wants to recompile gnome-base/bonobo-1.0.22 and it
fails to finish the compile with this:

> checking what warning flags to pass to the C compiler... -Wall -Wunused > checking what language compliance flags to pass to the C compiler... > checking for pthread_create in -lpthread... yes > checking for gtk-config... /usr/bin/gtk-config > checking for GTK - version >= 1.2.0... no > *** Could not run GTK test program, checking why... > *** The test program failed to compile or link. See the file > config.log for the > *** exact error that occured. This usually means GTK was incorrectly > installed > *** or that you have moved GTK since it was installed. In the latter > case, you > *** may want to edit the gtk-config script: /usr/bin/gtk-config > configure: error: GTK not installed > ./configure: line 8036: exit: or: numeric argument required > ./configure: line 8036: exit: or: numeric argument required > > !!! Please attach the config.log to your bug report: > !!! /var/tmp/portage/bonobo-1.0.22/work/bonobo-1.0.22/config.log > > !!! ERROR: gnome-base/bonobo-1.0.22 failed. > !!! Function econf, Line 485, Exitcode 0 > !!! econf failed > !!! If you need support, post the topmost build error, NOT this status > message. > > root@smoker / #
I did not move it because I don't know where it is. O_O This is what the gtk-config thing gives me:
> root@smoker / # gtk-config --version > 1.2.10 > root@smoker / #
I got that from man gtk-config by the way. Neat huh? This came from my emerge -s gtk. I wasn't sure what it was called OK. :/
> * x11-libs/gtk+ > Latest version available: 2.6.10 > Latest version installed: 2.6.10 > Size of downloaded files: 11,260 kB > Homepage: http://www.gtk.org/ > Description: Gimp ToolKit + > License: LGPL-2
It looks like I have 2.6.10 installed even though it says 1.2.10. What's up with this? How I fix it? Thanks much. Dale, :-) -- To err is human, I'm most certainly human. -- gentoo-dev@g.o mailing list

Replies

Subject Author
Re: [gentoo-dev] ERROR: gnome-base/bonobo-1.0.22 failed. Mike Williams <mike@××××××××.uk>
Re: [gentoo-dev] ERROR: gnome-base/bonobo-1.0.22 failed. Rumen Yotov <rumen_yotov@×××.bg>