Gentoo Archives: gentoo-dev

From: Mike Gilbert <floppym@g.o>
To: gentoo-dev@l.g.o
Cc: python@g.o
Subject: Re: [gentoo-dev] python.eclass EAPI 4 support, this gets really annoying
Date: Fri, 14 Oct 2011 21:53:42
Message-Id: 4E98AF3B.40405@gentoo.org
In Reply to: Re: [gentoo-dev] python.eclass EAPI 4 support, this gets really annoying by Matt Turner
On 10/14/2011 5:28 PM, Matt Turner wrote:
> On Fri, Oct 14, 2011 at 5:25 PM, Matthew Summers > <quantumsummers@g.o> wrote: >> Its being worked on currently. There are many fairly difficult issues >> to be worked through here. > > That's kind of the question though. What's are the issues?
The only issue that has been raised is that the eclass will die if python_pkg_setup is not called from the ebuild. This can happen either implicitly (the function is exported) or explicitly (by calling it from pkg_setup). I haven't gotten a very good explanation as to why this is necessary from Arfrever. He has given some very short, non-informative explanations like "Jython requires it". Puzzling it out myself takes quite a bit of brain power, given the complexity of the eclass. There may in fact be no reason for it at all. Either way, somebody needs to actually understand it. Other than that issue, I think we really just need to do some testing. Despite there being a large number of people in the python herd, there aren't many who actually have the time to do this. It would be helpful if folks could brain storm a list of python related packages to test under EAPI 4. I may have some time over the next few weekends to work on this.

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] python.eclass EAPI 4 support, this gets really annoying "Robin H. Johnson" <robbat2@g.o>