Gentoo Archives: gentoo-dev

From: Alin Nastac <mrness@g.o>
To: gentoo-dev@l.g.o
Subject: [gentoo-dev] RFC: emerge =net-dialup/ppp-2.4.3-r10 will fail requesting for user action
Date: Fri, 25 Nov 2005 18:55:22
Message-Id: 43875B72.8060305@gentoo.org
Hi all,

I plan to release a new version of net-dialup/ppp that will add support
for the pppd net module found in
sys-apps/baselayout-/baselayout-1.12.0_pre11.
This version, however, cannot work with the old /etc/init.d/net.ppp0,
hence I plan to die in pkg_setup with following messages:

 * Following files installed by previous versions of net-dialup/ppp
 * are obsoleted and need to be removed:
 *     /etc/conf.d/net.ppp0 - conflict with baselayout
 *     /etc/init.d/net.ppp0 - conflict with baselayout
 *     /etc/ppp/chat-default - unused by this version
 *     /etc/ppp/options-pppoe - unused by this version
 *     /etc/ppp/options-pptp - unused by this version

 * If you use the old net.ppp0 script, you need to:
 *    - upgrade to >=sys-apps/baselayout-1.12.0_pre11
 *    - set ppp0 parameters in /etc/conf.d/net (see example file)
 *    - remove conflicting files
 *    - upgrade net-dialup/ppp

 * If you never used net.ppp0 script, just run the following commands:
 *     rm //etc/conf.d/net.ppp0 //etc/init.d/net.ppp0
//etc/ppp/chat-default //etc/ppp/options-pppoe //etc/ppp/options-pptp
 *     emerge --resume

!!! ERROR: net-dialup/ppp-2.4.3-r10 failed.
!!! Function pkg_setup, Line 72, Exitcode 0
!!! Conflicts with baselayout support detected
!!! If you need support, post the topmost build error, NOT this status
message.

Please help me to improve the quality of these messages, at
informational or grammar level.

Attachments

File name MIME type
signature.asc application/pgp-signature