Gentoo Archives: gentoo-dev

From: "Manuel RĂ¼ger" <mrueg@g.o>
To: gentoo-dev@l.g.o
Cc: java@g.o, ruby@g.o, cpp@g.o, zerochaos@g.o, net-irc@g.o, naota@g.o, sci-geosciences@g.o, jdhore@g.o, mgorny@g.o
Subject: [gentoo-dev] Removal of dev-lang/ruby:1.9
Date: Wed, 26 Aug 2015 14:04:44
Message-Id: 55DDC762.7020300@gentoo.org
Hi,

as upstream stopped maintaining ruby 1.9 in February 2015, it is about
time to phase out ruby 1.9 support in Gentoo [1,2]. Recently ruby 2.1
has been stabilized on all supported architectures.
Therefore, the Ruby team will update RUBY_TARGETS from
RUBY_TARGETS="ruby19 ruby20" to RUBY_TARGETS="ruby20 ruby21".
This will enable support for ruby21 and remove the support for ruby19 at
the same time to keep the compilation effort for our users minimal.

See [2] for packages that require further attention by their
maintainers (CC'd).

Our schedule for the removal:

Today: Post news item to gentoo-dev
Today + 3d: Add news item to gentoo-news repository
Today + 1 week: Start masking USE="ruby" for packages that still rely on
ruby19 (again see [2]); update RUBY_TARGETS in base profile to "ruby20
ruby21"
Today + 2 weeks: Mask ruby 1.9 and deps for removal

Cheers,

Manuel


[1] https://bugs.gentoo.org/show_bug.cgi?id=536852
[2] https://wiki.gentoo.org/wiki/Project:Ruby/Ruby_1.9_deprecation

Attachments

File name MIME type
signature.asc application/pgp-signature