Gentoo Archives: gentoo-dev

From: Joshua Hansen <culthero@××××××××.info>
To: gentoo-user@g.o
Cc: gentoo-dev@g.o
Subject: [gentoo-dev] Re: [gentoo-user] portage revisited
Date: Thu, 14 Mar 2002 16:32:16
Message-Id: 1016144825.2532.12.camel@fightclub.culthero.info
1 I have found that about the only time you need to leave a previous
2 version on is if there is a large difference in the version number
3 (assuming you do regular updates). I like keeping things clean so I go
4 through and do my unmerges about once every week or two.
5
6 I'm thinking about writing a script (and the reason I bring this up is
7 if it already exists, point me to it so i don't waste the time) that
8 uses the qpkg --dups command and then lists and then asks if you want to
9 remove certain packages. Maybe even include an option to kill all
10 duplicates and just have a little file that contains things like
11 FreeType and DB.
12
13 Is there something like that? And, if anyone were interested in
14 including it with the scripts collection (like Gentools) what would be
15 the preferred language to write it in?
16
17 Joshua
18
19 On Thu, 2002-03-14 at 14:10, Rogan wrote:
20 > emerge --unmerge work fine. I am not sure if you neet to unmerge older versions of software, but from my experience, older versions are 'updated', ie. removed when you install a new version. When in doubt, don't unmerge ;)
21 >
22 > Rogan
23 >
24 > On Thu, 14 Mar 2002 13:28:01 -0800
25 > "Adam Ingram-Goble" <adam-aig@×××××.com> wrote:
26 >
27 > > the documentation on portage at the site is dated Oct 21, I'm wondering if
28 > > any new features (such as emerge --unmerge) have been implemented. also is
29 > > it critical that you unmerge some old version of some software, or can it
30 > > remain resident until you're sure its ok to get rid of?
31 > >
32 > > adam
33 > >
34 > > -----Original Message-----
35 > > From: gentoo-user-admin@g.o
36 > > [mailto:gentoo-user-admin@g.o]On Behalf Of Glenn E Burns
37 > > Sent: Thursday, March 14, 2002 12:51 PM
38 > > To: gentoo-user@g.o
39 > > Subject: Re: [gentoo-user] portage revisited
40 > >
41 > >
42 > > chad:
43 > >
44 > > i tried both emerge rsync/sync and i still got errors.... i'm doing an
45 > > emerge-webrsync right now and hopefully that will have the correct
46 > > ebuild files.
47 > >
48 > > worse comes to worse, I still have the portage binaries from the last
49 > > time this happened to me (_pre9)
50 > >
51 > > ...ok emerge-webrsync worked ... emerging portage... presto!
52 > >
53 > > all is well...
54 > >
55 > > peace!
56 > >
57 > > -g
58 > >
59 > > Chad M. Huneycutt wrote:
60 > >
61 > > > Glenn E Burns wrote:
62 > > >
63 > > >> last night i did "emerge --world update", all seemed ok until i tried
64 > > >> to do "emerge rsync" just a few moments ago... this is the error output:
65 > > >>
66 > > >> # emerge rsync
67 > > >> !!! not recognized; exiting.
68 > > >>
69 > > >> Calculating dependencies ...done!
70 > > >> [ebuild R ] sys-apps/portage-1.8.9_pre25 to /
71 > > >>
72 > > >> did portage-1.8.9_pre25 get unmasked and it wasn't supposed to be?
73 > > >
74 > > >
75 > > >
76 > > > Yep. emerge rsync (also try emerge sync), and emerge portage, and you
77 > > > should revert back to 1.8.8
78 > > >
79 > > > Sorry about that.
80 > > >
81 > >
82 > >
83 > > _______________________________________________
84 > > gentoo-user mailing list
85 > > gentoo-user@g.o
86 > > http://lists.gentoo.org/mailman/listinfo/gentoo-user
87 > >
88 > > _______________________________________________
89 > > gentoo-user mailing list
90 > > gentoo-user@g.o
91 > > http://lists.gentoo.org/mailman/listinfo/gentoo-user
92 > >
93 > >
94 > _______________________________________________
95 > gentoo-user mailing list
96 > gentoo-user@g.o
97 > http://lists.gentoo.org/mailman/listinfo/gentoo-user
98 >

Replies

Subject Author
Re: [gentoo-dev] Re: [gentoo-user] portage revisited Zach Forrest <zach@××××××××××××××.ca>
Re: [gentoo-dev] Re: [gentoo-user] portage revisited Bob Phan <bob@××××××××××××××××.net>