Gentoo Archives: gentoo-dev

From: Spider <spider@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Re: Emerge Update Slot
Date: Thu, 01 Apr 2004 17:46:23
In Reply to: [gentoo-dev] Re: Emerge Update Slot by Eamon Caddigan
begin  quote
On Thu, 1 Apr 2004 16:33:49 +0000 (UTC)
Eamon Caddigan <ecaddiga@××××.edu> wrote:

> Is there an easy way to tell emerge to update a package to the newest > version available in a given SLOT? Say I wanted to update to the > latest > unstable version of gtk1. If I try: > > $ ACCEPT_KEYWORDS="~x86" emerge -pvu \>=x11-libs/gtk+-1.2.10-r10 >
I'd go with ACCEPT_KEYWORDS="~x86" emerge -vpu '<x11-libs/gtk+-2' for this case. however portage needs slot based dependencies, I agree. //Spider -- begin .signature Tortured users / Laughing in pain See Microsoft KB Article Q265230 for more information. end


Subject Author
[gentoo-dev] Re: Emerge Update Slot Eamon Caddigan <ecaddiga@××××.edu>