Gentoo Archives: gentoo-dev

From: Nirbheek Chauhan <nirbheek@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Re: Please migrate to git-2.eclass
Date: Sat, 25 Jun 2011 14:21:39
In Reply to: [gentoo-dev] Re: Please migrate to git-2.eclass by Nikos Chantziaras
On Sat, Jun 25, 2011 at 1:26 PM, Nikos Chantziaras <realnc@×××××.de> wrote:
> On 06/25/2011 12:35 AM, Michał Górny wrote: >> >> Hello, >> >> git-2.eclass is in the tree for a while now, and there's still awful >> lot of packages using old&  deprecated git.eclass. > > I think I remember seeing deprecation warnings in the past when an ebuild > was using a deprecated eclass (right at the beginning when the emerge > starts.)  Perhaps it would be a good idea to add one of those in git.eclass. >
That's a horribly bad idea. Users should never need to see such things. The example you're thinking of is python.eclass, and that resulted in confused users filing bug reports. There's currently a repoman warning for git.eclass usage, and that suffices. -- ~Nirbheek Chauhan Gentoo GNOME+Mozilla Team